Back to overview
Degraded

Avatar and Icon Display Issues

Mar 29 at 06:36am GMT+3
Affected services
Website (discord.place)

Resolved
Apr 02 at 01:04pm GMT+3

The issue with avatars and icons not displaying correctly has been resolved, and everything is now functioning as expected.

Thank you for your patience during this time. If you encounter any further issues, please don't hesitate to reach out.

Created
Mar 29 at 06:36am GMT+3

We are aware that some avatars and icons are not displaying correctly in certain areas of the discord.place. The issue is currently being investigated, but there is no estimated time for a fix yet.

We appreciate your patience and will provide updates as soon as more information becomes available.