Back to overview
Downtime

Scheduled Maintenance Notice

Dec 17 at 08:18pm GMT+3

Resolved
Dec 18 at 12:04am GMT+3

Maintenance completed.

Created
Dec 17 at 08:18pm GMT+3

Our hosting provider will migrate our Proxy server from R9 3900 to AMD EPYC 7443P for improved performance.

  • Duration: ~3 hours

During this time, some features (e.g., voting) may not work correctly. We appreciate your patience and understanding.